<!DOCTYPE html>
<html lang="en-US">
	<head>
		<meta charset="UTF-8" />
		<title>Predictive Processing And Perceptual Control | Slate Star Codex</title>
		<meta name=viewport content="width=device-width, min-width=572, initial-scale=1">
		<script type="text/javascript" src="http://slatestarcodex.com/wp-content/themes/responsive-pujugama-v2/viewport-min-width.js"></script>
		<link rel="profile" href="http://gmpg.org/xfn/11" />
		<link rel="stylesheet" type="text/css" media="all" href="http://slatestarcodex.com/wp-content/themes/responsive-pujugama-v2/style.css" />
		<link href='https://fonts.googleapis.com/css?family=Raleway' rel='stylesheet' type='text/css'>
		<link href='https://fonts.googleapis.com/css?family=Josefin+Sans' rel='stylesheet' type='text/css'>
		<link rel='stylesheet' id='font-awesome-css'  href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.3.0/css/font-awesome.min.css' type='text/css' media='all' />

		<link rel="pingback" href="http://slatestarcodex.com/xmlrpc.php" />
		<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel="alternate" type="application/rss+xml" title="Slate Star Codex &raquo; Feed" href="http://slatestarcodex.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Slate Star Codex &raquo; Comments Feed" href="http://slatestarcodex.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Slate Star Codex &raquo; Predictive Processing And Perceptual Control Comments Feed" href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/feed/" />
<link rel='stylesheet' id='simple-payments-css'  href='http://slatestarcodex.com/wp-content/plugins/jetpack/modules/simple-payments/simple-payments.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wmsimplecaptcha_style_front-css'  href='http://slatestarcodex.com/wp-content/plugins/wm-simple-captcha/assets/css/wmsimplecaptcha_style.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://slatestarcodex.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://slatestarcodex.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.2.1' type='text/css' media='all' />
<script type='text/javascript' src='http://slatestarcodex.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://slatestarcodex.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/slatestarcodex.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://slatestarcodex.com/wp-content/plugins/wm-simple-captcha/assets/js/wmsimplecaptcha_scripts.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://slatestarcodex.com/wp-content/plugins/wp-hide-post/public/js/wp-hide-post-public.js?ver=2.0.10'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga'></script>
<link rel='https://api.w.org/' href='http://slatestarcodex.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://slatestarcodex.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://slatestarcodex.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Open Thread 83.75' href='http://slatestarcodex.com/2017/09/06/open-thread-83-75/' />
<link rel="canonical" href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/" />
<link rel='shortlink' href='http://slatestarcodex.com/?p=4603' />
<link rel="alternate" type="application/json+oembed" href="http://slatestarcodex.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://slatestarcodex.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F&#038;format=xml" />
			<style type="text/css">
				.pmcc-comments-report-link {
					font: 10px sans-serif;
					display:block;
					float:right;
					clear: left;
					margin-top: 10px;
				}
				.pmcc-comments-report-link a {
					color: #9C3E3E;
					padding: 2px 5px;
					margin: 2px 0 0 5px;
					border: 1px solid #ddd;
				}
				
				.pmcc-comments-report-link strong {
				    color: white;
				    background: #c0392b;
				    padding-top: 2px;
				    border-radius: 7px;
				    display: block;
				    width: 15px;
				    height: 15px;
				    text-align: center;
				    margin-right: 10px;
				}
			</style>
			
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Predictive Processing And Perceptual Control" />
<meta property="og:url" content="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/" />
<meta property="og:description" content="Yesterday&#8217;s review of Surfing Uncertainty mentioned how predictive processing attributes movement to strong predictions about proprioceptive sensations. Because the brain tries to minimize pr…" />
<meta property="article:published_time" content="2017-09-07T02:16:14+00:00" />
<meta property="article:modified_time" content="2017-09-07T03:19:10+00:00" />
<meta property="og:site_name" content="Slate Star Codex" />
<meta property="og:image" content="http://slatestarcodex.com/wp-content/themes/two_column_pujugama/images/codex_spotlight.png" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />
<meta property="og:image:width" content="200" />
<meta property="og:image:height" content="200" />
<meta name="twitter:site" content="@slatestarcodex" />
	</head>

	<body class="post-template-default single single-post postid-4603 single-format-standard s1-collapse s2-collapse">
		<div id="pjgm-wrap">
			<div id="pjgm-header">
				<div id="pjgm-menubar">
					<a href="http://slatestarcodex.com/" class="pjgm-home" title="Slate Star Codex" rel="home">Home</a>
					<div class="menu"><ul>
<li class="page_item page-item-2"><a href="http://slatestarcodex.com/about/">About / Top Posts</a></li>
<li class="page_item page-item-2091"><a href="http://slatestarcodex.com/archives/">Archives</a></li>
<li class="page_item page-item-4475"><a href="http://slatestarcodex.com/meetups/">Meetups</a></li>
<li class="page_item page-item-3837"><a href="http://slatestarcodex.com/mistakes/">Mistakes</a></li>
<li class="page_item page-item-1745"><a href="http://slatestarcodex.com/comments/">Comments</a></li>
<li class="page_item page-item-4223"><a href="http://slatestarcodex.com/predictions-bets/">Predictions &#038; Bets</a></li>
<li class="page_item page-item-3942"><a href="http://slatestarcodex.com/advertise/">Advertise</a></li>
<li class="page_item page-item-3989"><a href="/tag/open/?latest">Open Thread</a></li>
</ul></div>
					<a href="http://slatestarcodex.com/comments/feed/" class="pjgm-feed">Comments Feed</a>
					<a href="http://slatestarcodex.com/feed/" class="pjgm-feed">RSS Feed</a>
				</div><!-- #pjgm-menubar -->

				<div id="pjgm-bigtitle">
										<div id="pjgm-title">
						<img src="http://slatestarcodex.com/wp-content/themes/responsive-pujugama-v2/images/codex.png" alt="codex" class="codex" />
						<span>
							<a href="http://slatestarcodex.com/" title="Slate Star Codex" rel="home">Slate Star Codex</a>
						</span>
						</div>
						<div id="pjgm-description">&quot;Talks a good game about freedom when out of power, but once he’s in &#8211; bam! Everyone&#039;s enslaved in the human-flourishing mines.&quot;</div>
			</div><!-- #pjgm-bigtitle -->
		</div><!-- #pjgm-header -->

		<div id="pjgm-main">
<div id="left-sidebar" class="widget-area" role="complementary">
	<a class="sidebar-toggle" title="Expand Sidebar"><i class="fa fa-angle-double-left"></i><i class="fa fa-angle-double-right"></i></a>
	<ul class="xoxo">
				<li id="recent-posts-2" class="widget-container widget_recent_entries">		<h3 class="widget-title">Recent Posts</h3>		<ul>
					<li>
				<a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/">Predictive Processing And Perceptual Control</a>
						</li>
					<li>
				<a href="http://slatestarcodex.com/2017/09/06/open-thread-83-75/">Open Thread 83.75</a>
						</li>
					<li>
				<a href="http://slatestarcodex.com/2017/09/05/book-review-surfing-uncertainty/">Book Review: Surfing Uncertainty</a>
						</li>
					<li>
				<a href="http://slatestarcodex.com/2017/09/03/open-thread-83-5/">Open Thread 83.5</a>
						</li>
					<li>
				<a href="http://slatestarcodex.com/2017/08/31/highlights-from-the-comments-on-my-irb-nightmare/">Highlights From The Comments On My IRB Nightmare</a>
						</li>
				</ul>
		</li>		<li id="text-3" class="widget-container widget_text"><h3 class="widget-title">Blogroll</h3>			<div class="textwidget"></div>
		</li><li id="linkcat-100" class="widget-container widget_links"><h3 class="widget-title">Embalmed Ones</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://blog.jaibot.com/">ANOIEAEIB</a></li>
<li><a href="http://commonsenseatheism.com/">Common Sense Atheism</a></li>
<li><a href="http://lesswrong.com">Less Wrong</a></li>
<li><a href="http://thelastpsychiatrist.com/">The Last Psychiatrist</a></li>

	</ul>
</li>
<li id="linkcat-95" class="widget-container widget_links"><h3 class="widget-title">Fabulous Ones</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://alicorn.elcenia.com/board/index.php">Alicornutopia</a></li>
<li><a href="http://unsongbook.com">Unsong</a></li>
<li><a href="https://parahumans.wordpress.com/">Worm</a></li>

	</ul>
</li>
<li id="linkcat-98" class="widget-container widget_links"><h3 class="widget-title">Innumerable Ones</h3>
	<ul class='xoxo blogroll'>
<li><a href="https://www.gwern.net/">Gwern</a></li>
<li><a href="https://golem.ph.utexas.edu/category/">n-Category Cafe</a></li>
<li><a href="http://putanumonit.com/">Put A Number On It</a></li>
<li><a href="https://randomcriticalanalysis.wordpress.com">Random Critical Analysis</a></li>
<li><a href="http://www.scottaaronson.com/blog/">Shtetl-Optimized</a></li>
<li><a href="http://andrewgelman.com/">Statistical Modeling</a></li>
<li><a href="http://unenumerated.blogspot.com/">Unenumerated</a></li>

	</ul>
</li>
<li id="linkcat-94" class="widget-container widget_links"><h3 class="widget-title">Mermaids</h3>
	<ul class='xoxo blogroll'>
<li><a href="https://intelligence.org/blog/">MIRI</a></li>
<li><a href="http://freethoughtblogs.com/brutereason/">Miri</a></li>
<li><a href="http://nothingismere.com/">Nothing Is Mere</a></li>
<li><a href="https://themerelyreal.wordpress.com/">The Merely Real</a></li>

	</ul>
</li>
<li id="linkcat-96" class="widget-container widget_links"><h3 class="widget-title">Stray Dogs</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://anonymousmugwump.blogspot.co.uk">Anonymous Mugwump</a></li>
<li><a href="http://followthesquirrel.blogspot.com/">Follow The Squirrel</a></li>
<li><a href="http://marginalrevolution.com/">Marginal Revolution</a></li>
<li><a href="https://nintil.com/">Nintil</a></li>
<li><a href="https://pseudoerasmus.com/">Pseudoerasmus</a></li>
<li><a href="http://www.themoneyillusion.com/">The Money Illusion</a></li>

	</ul>
</li>
<li id="linkcat-101" class="widget-container widget_links"><h3 class="widget-title">Suckling Pigs</h3>
	<ul class='xoxo blogroll'>
<li><a href="https://fredrikdeboer.com/anova/">Fredrik deBoer</a></li>
<li><a href="http://unqualifiedrestaurants.tumblr.com/">Unqualified Restaurant Reservations</a></li>
<li><a href="http://wholehealthsource.blogspot.com/">Whole Health Source</a></li>

	</ul>
</li>
<li id="linkcat-91" class="widget-container widget_links"><h3 class="widget-title">Those Drawn With A Very Fine Camel Hair Brush</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://existentialcomics.com/">Existential Comics</a></li>
<li><a href="http://www.smbc-comics.com/">Saturday Morning Breakfast Cereal</a></li>

	</ul>
</li>
<li id="linkcat-89" class="widget-container widget_links"><h3 class="widget-title">Those That Are Included In This Classification</h3>
	<ul class='xoxo blogroll'>
<li><a href="https://www.reddit.com/r/slatestarcodex/">r/slatestarcodex</a></li>
<li><a href="https://discordapp.com/invite/gpaTCxh">SSC Discord Server</a></li>

	</ul>
</li>
<li id="linkcat-93" class="widget-container widget_links"><h3 class="widget-title">Those That Are Trained</h3>
	<ul class='xoxo blogroll'>
<li><a href="https://80000hours.org/blog/">80000 Hours Blog</a></li>
<li><a href="http://aiimpacts.org/">AI Impacts</a></li>
<li><a href="http://www.effective-altruism.com/">Effective Altruism Forum</a></li>
<li><a href="http://blog.givewell.org/">GiveWell Blog</a></li>
<li><a href="http://www.jefftk.com/index">Jeff Kaufman</a></li>
<li><a href="http://lukemuehlhauser.com/">Luke Muehlhauser</a></li>
<li><a href="http://theunitofcaring.tumblr.com/">The Unit of Caring</a></li>
<li><a href="https://thewholesky.wordpress.com/">The Whole Sky</a></li>

	</ul>
</li>
<li id="linkcat-102" class="widget-container widget_links"><h3 class="widget-title">Those That At A Distance Resemble Flies</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://agentyduck.blogspot.com/">Agenty Duck</a></li>
<li><a href="https://www.beeminder.com/">Beeminder</a></li>
<li><a href="http://mindingourway.com/">Nate Soares</a></li>

	</ul>
</li>
<li id="linkcat-99" class="widget-container widget_links"><h3 class="widget-title">Those That Belong To The Emperor</h3>
	<ul class='xoxo blogroll'>
<li><a href="https://samzdat.com">Sam[]zdat</a></li>
<li><a href="https://westhunt.wordpress.com/">West Hunter</a></li>
<li><a href="http://www.xenosystems.net/">Xenosystems</a></li>

	</ul>
</li>
<li id="linkcat-97" class="widget-container widget_links"><h3 class="widget-title">Those That Have Just Broken The Flower Vase</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://esr.ibiblio.org/">Armed and Dangerous</a></li>
<li><a href="http://econlog.econlib.org/authorbcaplan.html">Bryan Caplan</a></li>
<li><a href="http://daviddfriedman.blogspot.com/">David Friedman</a></li>
<li><a href="https://thezvi.wordpress.com/">Don&#039;t Worry About The Vase</a></li>
<li><a href="http://www.overcomingbias.com/">Overcoming Bias</a></li>
<li><a href="http://www.popehat.com/">Popehat</a></li>

	</ul>
</li>
<li id="linkcat-90" class="widget-container widget_links"><h3 class="widget-title">Those That Tremble As Though They Are Mad</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://1boringoldman.com/">1 Boring Old Man</a></li>
<li><a href="http://acesounderglass.com/">Aceso Under Glass</a></li>
<li><a href="http://cognitionandevolution.blogspot.com/">Cognition and Evolution</a></li>
<li><a href="http://www.crazymeds.us/">Crazy Meds</a></li>
<li><a href="http://gruntledandhinged.wordpress.com/">Gruntled and Hinged</a></li>
<li><a href="http://real-psychiatry.blogspot.com/">Real Psychiatry</a></li>
<li><a href="http://psychiatrist-blog.blogspot.com/">Shrink Rap</a></li>

	</ul>
</li>
<li id="linkcat-92" class="widget-container widget_links"><h3 class="widget-title">Various Others</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://zackmdavis.net/blog/">An Algorithmic Lucidity</a></li>
<li><a href="http://www.unz.com/gnxp/">Gene Expression</a></li>
<li><a href="http://infoproc.blogspot.com/">Information Processing</a></li>
<li><a href="http://www.meltingasphalt.com/">Melting Asphalt</a></li>
<li><a href="https://meteuphoric.wordpress.com/">Meteuphoric</a></li>
<li><a href="https://srconstantin.wordpress.com/">Otium</a></li>
<li><a href="http://www.ribbonfarm.com/">Ribbonfarm</a></li>
<li><a href="http://rationalconspiracy.com/">The Rationalist Conspiracy</a></li>
<li><a href="https://sideways-view.com/">The Sideways View</a></li>
<li><a href="http://thingofthings.wordpress.com/">Thing of Things</a></li>
<li><a href="https://weird.solar">Weird Sun Blog</a></li>

	</ul>
</li>
<li id="archives-2" class="widget-container widget_archive"><h3 class="widget-title">Archives</h3>		<ul>
			<li><a href='http://slatestarcodex.com/2017/09/'>September 2017</a></li>
	<li><a href='http://slatestarcodex.com/2017/08/'>August 2017</a></li>
	<li><a href='http://slatestarcodex.com/2017/07/'>July 2017</a></li>
	<li><a href='http://slatestarcodex.com/2017/06/'>June 2017</a></li>
	<li><a href='http://slatestarcodex.com/2017/05/'>May 2017</a></li>
	<li><a href='http://slatestarcodex.com/2017/04/'>April 2017</a></li>
	<li><a href='http://slatestarcodex.com/2017/03/'>March 2017</a></li>
	<li><a href='http://slatestarcodex.com/2017/02/'>February 2017</a></li>
	<li><a href='http://slatestarcodex.com/2017/01/'>January 2017</a></li>
	<li><a href='http://slatestarcodex.com/2016/12/'>December 2016</a></li>
	<li><a href='http://slatestarcodex.com/2016/11/'>November 2016</a></li>
	<li><a href='http://slatestarcodex.com/2016/10/'>October 2016</a></li>
	<li><a href='http://slatestarcodex.com/2016/09/'>September 2016</a></li>
	<li><a href='http://slatestarcodex.com/2016/08/'>August 2016</a></li>
	<li><a href='http://slatestarcodex.com/2016/07/'>July 2016</a></li>
	<li><a href='http://slatestarcodex.com/2016/06/'>June 2016</a></li>
	<li><a href='http://slatestarcodex.com/2016/05/'>May 2016</a></li>
	<li><a href='http://slatestarcodex.com/2016/04/'>April 2016</a></li>
	<li><a href='http://slatestarcodex.com/2016/03/'>March 2016</a></li>
	<li><a href='http://slatestarcodex.com/2016/02/'>February 2016</a></li>
	<li><a href='http://slatestarcodex.com/2016/01/'>January 2016</a></li>
	<li><a href='http://slatestarcodex.com/2015/12/'>December 2015</a></li>
	<li><a href='http://slatestarcodex.com/2015/11/'>November 2015</a></li>
	<li><a href='http://slatestarcodex.com/2015/10/'>October 2015</a></li>
	<li><a href='http://slatestarcodex.com/2015/09/'>September 2015</a></li>
	<li><a href='http://slatestarcodex.com/2015/08/'>August 2015</a></li>
	<li><a href='http://slatestarcodex.com/2015/07/'>July 2015</a></li>
	<li><a href='http://slatestarcodex.com/2015/06/'>June 2015</a></li>
	<li><a href='http://slatestarcodex.com/2015/05/'>May 2015</a></li>
	<li><a href='http://slatestarcodex.com/2015/04/'>April 2015</a></li>
	<li><a href='http://slatestarcodex.com/2015/03/'>March 2015</a></li>
	<li><a href='http://slatestarcodex.com/2015/02/'>February 2015</a></li>
	<li><a href='http://slatestarcodex.com/2015/01/'>January 2015</a></li>
	<li><a href='http://slatestarcodex.com/2014/12/'>December 2014</a></li>
	<li><a href='http://slatestarcodex.com/2014/11/'>November 2014</a></li>
	<li><a href='http://slatestarcodex.com/2014/10/'>October 2014</a></li>
	<li><a href='http://slatestarcodex.com/2014/09/'>September 2014</a></li>
	<li><a href='http://slatestarcodex.com/2014/08/'>August 2014</a></li>
	<li><a href='http://slatestarcodex.com/2014/07/'>July 2014</a></li>
	<li><a href='http://slatestarcodex.com/2014/06/'>June 2014</a></li>
	<li><a href='http://slatestarcodex.com/2014/05/'>May 2014</a></li>
	<li><a href='http://slatestarcodex.com/2014/04/'>April 2014</a></li>
	<li><a href='http://slatestarcodex.com/2014/03/'>March 2014</a></li>
	<li><a href='http://slatestarcodex.com/2014/02/'>February 2014</a></li>
	<li><a href='http://slatestarcodex.com/2014/01/'>January 2014</a></li>
	<li><a href='http://slatestarcodex.com/2013/12/'>December 2013</a></li>
	<li><a href='http://slatestarcodex.com/2013/11/'>November 2013</a></li>
	<li><a href='http://slatestarcodex.com/2013/10/'>October 2013</a></li>
	<li><a href='http://slatestarcodex.com/2013/09/'>September 2013</a></li>
	<li><a href='http://slatestarcodex.com/2013/08/'>August 2013</a></li>
	<li><a href='http://slatestarcodex.com/2013/07/'>July 2013</a></li>
	<li><a href='http://slatestarcodex.com/2013/06/'>June 2013</a></li>
	<li><a href='http://slatestarcodex.com/2013/05/'>May 2013</a></li>
	<li><a href='http://slatestarcodex.com/2013/04/'>April 2013</a></li>
	<li><a href='http://slatestarcodex.com/2013/03/'>March 2013</a></li>
	<li><a href='http://slatestarcodex.com/2013/02/'>February 2013</a></li>
		</ul>
		</li><li id="nav_menu-3" class="widget-container widget_nav_menu"><div class="menu-full-archives-link-for-widget-area-container"><ul id="menu-full-archives-link-for-widget-area" class="menu"><li id="menu-item-2103" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2103"><a href="http://slatestarcodex.com/archives/">Full Archives</a></li>
</ul></div></li>	</ul>
</div>

		<div id="pjgm-box">
			<div id="pjgm-content">


				<div id="post-4603" class="post-4603 post type-post status-publish format-standard hentry category-uncategorized tag-psychology">
					<h1 class="pjgm-posttitle">Predictive Processing And Perceptual Control</h1>

					<div class="pjgm-postmeta">
						<span class="meta-prep meta-prep-author">Posted on</span> <a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/" title="7:16 pm" rel="bookmark"><span class="entry-date">September 6, 2017</span></a> <span class="meta-sep">by</span> <span class="author vcard"><a class="url fn n" href="http://slatestarcodex.com/author/admin/" title="View all posts by Scott Alexander">Scott Alexander</a></span>					</div><!-- .pjgm-postmeta -->

					<div class="pjgm-postcontent">
						<p>Yesterday&#8217;s review of <i>Surfing Uncertainty</i> mentioned how predictive processing attributes movement to strong predictions about proprioceptive sensations. Because the brain tries to minimize predictive error, it moves the limbs into the positions needed to produce those sensations, fulfilling its own prophecy.</p>
<p>This was a really difficult concept for me to understand at first. But there were a couple of passages that helped me make an important connection. See if you start thinking the same thing I&#8217;m thinking:</p>
<blockquote><p>To make [bodily] action come about, the motor plant behaves (Friston, Daunizeau, et al, 2010) in ways that cancel out proprioceptive prediction errors. This works because the proprioceptive prediction errors signal the difference between how the bodily plant is currently disposed and how it would be disposed were the desired actions being performed. Proprioceptive prediction error will yield (moment-by-moment) the projected proprioceptive inputs. In this way, predictions of the unfolding proprioceptive patterns that would be associated with the performance of some action actually bring that action about. This kind of scenario is neatly captured by Hawkins and Blakeslee (2004), who write that: &#8220;As strange as it sounds, when your own behavior is involved, your predictions not only precede sensation, they determine sensation.&#8221;</p></blockquote>
<p>And:</p>
<blockquote><p>PP thus implements the distinctive circular dynamics described by Cisek and Kalaska using a famous quote from the American pragmatist John Dewey. Dewey rejects the &#8216;passive&#8217; model of stimuli evoking responses in favour of an active and circular model in which &#8216;the motor response determines the stimulus, just as truly as sensory stimulus determines movement&#8217;</p></blockquote>
<p>Still not getting it? What about:</p>
<blockquote><p>According to active inference, the agent moves body and sensors in ways that amount to actively seeking out the sensory consequences that their brains expect.</p></blockquote>
<p>This is the model from Will Powers&#8217; <A HREF="http://slatestarcodex.com/2017/03/06/book-review-behavior-the-control-of-perception/">Behavior: The Control Of Perception</A>.</p>
<p>Clark knows this. A few pages after all these quotes, he writes:</p>
<blockquote><p>One signature of this kind of grip-based non-reconstructive dance is that it suggests a potent reversal of our ordinary way of thinking about the relations between perception and action. Instead of seeing perception as the control of action, it becomes fruitful to think of action as the control of perception [Powers 1973, Powers et al, 2011].</p></blockquote>
<p>But I feel like this connection should be given more weight. Powers&#8217; perceptual control theory presages predictive processing theory in a lot of ways. In particular, both share the idea of cogntitive &#8220;layers&#8221;, which act at various levels (light-intensity-detection vs. edge-detection vs. object-detection, or movements vs. positions-in-space vs. specific-muscle-actions vs. specific-muscle-fiber-tensions). Upper layers decide what stimuli they want lower levels to be perceiving, and lower layers arrange themselves in the way that produce those stimuli. PCT talks about &#8220;set points&#8221; for cybernetic systems, and PP talks about &#8220;predictions&#8221;, but they both seem to be groping at the same thing.</p>
<p>I was least convinced by the part of PCT which represented the uppermost layers of the brain as control systems controlling various quantities like &#8220;love&#8221; or &#8220;communism&#8221;, and which sometimes seemed to veer into self-parody. PP offers an alternative by describing those layers as making predictions (sometimes &#8220;active predictions&#8221; of the sort that guide behavior) and trying to minimize predictive error. This allows lower level systems to &#8220;control for&#8221; deviation from a specific plan, rather than just monitoring the amount of some scalar quantity.</p>
<p>My review of <i>Behavior: The Control Of Perception</i> ended by saying:</p>
<blockquote><p>It does seem like there’s something going on where my decision to drive activates a lot of carefully-trained subsystems that handle the rest of it automatically, and that there’s probably some neural correlate to it. But I don’t know whether control systems are the right way to think about this&#8230; I think maybe there are some obvious parallels, maybe even parallels that bear fruit in empirical results, in lower level systems like motor control. Once you get to high-level systems like communism or social desirability, I’m not sure we’re doing much better than [strained control-related metaphors].</p></blockquote>
<p>I think my instincts were right. PCT is a good model, but what&#8217;s good about it is that it approximates PP. It approximates PP best at the lower levels, and so is most useful there; its thoughts on the higher levels remain useful but start to diverge and so become less profound.</p>
<p>The Greek atomists like Epicurus have been totally superseded by modern atomic theory, but they still get a sort of &#8220;how did they do that?&#8221; award for using vague intuition and good instincts to cook up a scientific theory that couldn&#8217;t be proven or universally accepted until centuries later. If PP proves right, then Will Powers and PCT deserve a place in the pantheon besides them. There&#8217;s something kind of wasteful about this &#8211; we can&#8217;t properly acknowledge the cutting-edgeness of their contribution until it&#8217;s obsolete &#8211; but at the very least we can look through their other work and see if they&#8217;ve got even <i>more</i> smart ideas that might be ahead of their time.</p>
<p>(Along with his atomic theory, Epicurus gathered a bunch of philosophers and <A HREF="https://en.wikipedia.org/wiki/Polyaenus_of_Lampsacus">mathematicians</A> into a small <A HREF="https://en.wikipedia.org/wiki/Epicurus#Hero_cult">cult</A> around him, who lived together in <A HREF="http://classicalwisdom.com/epicureanism-original-hippie-commune-birth-american-dream/">co-ed group houses</A> preaching atheism and materialism and &#8211; as per the rumors &#8211; having <A HREF="https://books.google.com/books?id=ZdlXAQAAQBAJ&#038;pg=PA19&#038;lpg=PA19&#038;dq=Epicurus+garden+orgies&#038;source=bl&#038;ots=Nb5k2ZN7-8&#038;sig=_5DvQmEkDTlNG4t2iIY2XsDpu-s&#038;hl=en&#038;sa=X&#038;ved=0ahUKEwj7mJqwk43WAhVErVQKHScPD30Q6AEIPTAE#v=onepage&#038;q=Epicurus%20garden%20orgies&#038;f=false">orgies</A>. If we&#8217;d just agreed he was <A HREF="http://slatestarcodex.com/2015/07/23/the-general-factor-of-correctness/">right about everything</A> from the start, we wouldn&#8217;t have had to laboriously reinvent his whole system.)</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-4603" class="share-twitter sd-button share-icon" href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-4603" class="share-facebook sd-button share-icon" href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div>											</div><!-- .pjgm-postcontent -->


					<div class="pjgm-postutility">
						This entry was posted in <a href="http://slatestarcodex.com/category/uncategorized/" rel="category tag">Uncategorized</a> and tagged <a href="http://slatestarcodex.com/tag/psychology/" rel="tag">psychology</a>. Bookmark the <a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/" title="Permalink to Predictive Processing And Perceptual Control" rel="bookmark">permalink</a>.											</div><!-- .pjgm-postutility -->
				</div><!-- #post-## -->

				<div id="pjgm-navbelow" class="pjgm-navigation">
					<div class="pjgm-navpre"><a href="http://slatestarcodex.com/2017/09/06/open-thread-83-75/" rel="prev"><span class="pjgm-metanav">&larr;</span> Open Thread 83.75</a></div>
					<div class="pjgm-navnex"></div>
				</div><!-- #pjgm-navbelow -->

				


	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/09/06/predictive-processing-and-perceptual-control/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	

	<div id="comments">
			<h3 id="comments-title">20 Responses to <em>Predictive Processing And Perceptual Control</em></h3>


			<ol class="commentlist">
					<li class="comment byuser comment-author-vaniver even thread-even depth-1" id="li-comment-544477">
		<div id="comment-544477" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://1.gravatar.com/avatar/da6a2ff0d8edde66deac86e4fc3e326a?s=40&#038;d=identicon&#038;r=g' srcset='http://1.gravatar.com/avatar/da6a2ff0d8edde66deac86e4fc3e326a?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">vaniver</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544477">
			September 6, 2017 at 7:56 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><blockquote><p>I think my instincts were right. PCT is a good model, but what’s good about it is that it approximates PP.</p></blockquote>
<p>Something about this framing is bothering me. One thing is that error-minimization and surprisal-minimization should look basically the same, and so it&#8217;s not obvious that framing one as approximating the other is better than framing them as isomorphic to each other. (Whether or not they&#8217;re actually isomorphic depends on the math going on underneath, but I think both frameworks could be consistent with any expected experimental results and major aspects of each seem natural and consistent with each other.)</p>
<p>Another thing is that control systems seem better motivated than prediction systems. In the PCT framing, there&#8217;s the neural hierarchical control framework, and then another sub-neural control system that modifies the neural hierarchy that isn&#8217;t well understood. (This seems to be related to stuff like calorie acquisition and sexual satisfaction and so on, such that those are inherently rewarding in some way.) I don&#8217;t think the surprisal-minimization framework has an explanation for eating food being rewarding, but the controls framework can.</p>
<p>And, in general, when you think of people as agents, agents acting to control their perceptions seems like a better framing than agents predicting what they&#8217;ll do and then doing that (especially if they predict that they&#8217;ll act to control their perceptions!). In particular, think about Bayes scores, which are canonically measured as the log of predictions of events, which are always <i>negative</i>; an agent that just seeks to minimize surprisal is better off receiving no sensory data by being dead! An agent that seeks to maintain homeostatic balance observes that being dead is not being homeostatically balanced.</p>
<p>&#8212;</p>
<p>While I started out writing this comment because that framing rubbed me the wrong way, I think I should just state my overall position: I view PP and PCT as basically isomorphic, with PP how you would look at things from a unsupervised learning frame and PCT how you would look at things from a supervised learning frame. But one of the obvious things to do in a supervised learning agent in a big world is for it to <i>also</i> have unsupervised learning capabilities, and encourage using them at the right levels through something like curiosity, boredom, and overstimulation. Given the deep mathematical similarities, that means a synthesis of the two frames is very simple and seems desirable.</p>
<p>(But it also seems to me like PCT is the foundational frame; at their heart, it looks like people want homeostatic balance, not perfect prediction, and predictions are just extremely useful tools at reaching homeostatic balance in a big world.)</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment byuser comment-author-blueacritter odd alt depth-2" id="li-comment-544479">
		<div id="comment-544479" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://1.gravatar.com/avatar/706bcb570414cbb92ccbfc9e6f1cf590?s=40&#038;d=identicon&#038;r=g' srcset='http://1.gravatar.com/avatar/706bcb570414cbb92ccbfc9e6f1cf590?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Sam Reuben</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544479">
			September 6, 2017 at 8:13 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>As a question: couldn&#8217;t things such as curiosity and boredom serve as supervisions, if you take as default the desires for knowledge and activity respectively? Many learning frames could thus be described as unsupervised within their own limited context (e.g. the process of learning to bring a spoon to your mouth is internally governed by avoiding the surprise of boiling soup ending up where it shouldn&#8217;t be) but ultimately organized by a fairly standard and straightforward set of principles, with the key one being an acquisition of new and more powerful predictive models. Otherwise, there would seem to be a slight disconnect between the unsupervised frame and the supervised one, where (as you so accurately point out) the proper goal for the unsupervised frame is to simply avoid all new data whatsoever.</p>
<p>(In fact, this might be explanatory for people who seem to avoid any kind of &#8220;unsupervised learning&#8221; and have very little curiosity: for whatever reason, their knowledge drives are low in the same way as some people have low sex drives, and thus they seek to shut out all potential disruptive stimulus on those fronts by avoiding anything that might make them think.)</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment byuser comment-author-shambaug even depth-2" id="li-comment-544491">
		<div id="comment-544491" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://2.gravatar.com/avatar/e6cb2985fc9a2032449e204660f6572d?s=40&#038;d=identicon&#038;r=g' srcset='http://2.gravatar.com/avatar/e6cb2985fc9a2032449e204660f6572d?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Scott</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544491">
			September 6, 2017 at 8:48 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>I work as a controls engineer, and while I all I know about PCT and PP at the moment is what I&#8217;ve read in these 3 posts, I was thinking that I would implement them exactly the same way. So yes, based on what&#8217;s here I&#8217;d agree they&#8217;re isomorphic. Maybe Scott didn&#8217;t agree with the things that Powers thought were being controlled for at a higher level? That&#8217;s incidental to the theory IMO &#8211; the framework looks the same. </p>
<p>Every large scale dynamic electronic machine (airplane, petroleum plant, etc) is controlled by a hierarchical system of observer-predictor-controller loops. These pass information between layers not with the low level information they operate on, but an &#8220;error signal&#8221; which is the difference between their measured output and predicted output. You can stack as many of these up as you want, and get a coherent self-correcting output at every level from an abstract concept like &#8220;fly me to New York&#8221;. Or you oscillate wildly when something in your model is broken. Add in stuff like adaptive control and you can start to see a pretty nice formalized model of things we see in biology (I&#8217;d love to read more on people who have applied this to biological processes &#8211; the different neurochemicals being used as different pathways here is super interesting. Flood of dopamine in the brain = all error signals go to 0 = everything is right in the world?). PP and PCT both seem to be doing this. It&#8217;s a way of approaching our thought process that makes a lot of sense to me. </p>
<p>If it&#8217;s control systems all the way up, this way of looking at cognition implies a single measure of goodness that is being maximized at the highest level. Perhaps an evolutionary survive &amp; thrive imperative that is going on above the levels we are conscious at? It fits pretty well with ideas about executive functions. But now I&#8217;m getting out of my area of expertise.</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment byuser comment-author-admin bypostauthor odd alt depth-2" id="li-comment-544497">
		<div id="comment-544497" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://0.gravatar.com/avatar/c66389ad74ef2a291c76e87c981b0391?s=40&#038;d=identicon&#038;r=g' srcset='http://0.gravatar.com/avatar/c66389ad74ef2a291c76e87c981b0391?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Scott Alexander</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544497">
			September 6, 2017 at 9:09 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>&#8220;An agent that just seeks to minimize surprisal is better off receiving no sensory data by being dead! An agent that seeks to maintain homeostatic balance observes that being dead is not being homeostatically balanced.&#8221;</p>
<p>If you having Surfing Uncertainty or want to borrow it from me, this is addressed in Section 8.10, but it&#8217;s hard to understand and not very convincing. It seems to be one part repeating the word &#8220;embodiment&#8221; like a mantra, one part saying &#8220;Yeah, okay, that&#8217;s because of something other than predictive processing, we didn&#8217;t say this model explained <i>everything</i>, and one part basically Powers&#8217; solution &#8211; saying that we have hard-coded &#8220;predictions&#8221; of getting enough to eat or being the right temperature or whatever.</p>
<p>Interestingly, Clark&#8217;s description of what a hypothetical predictive agent that really tried to minimize surprisal without these constraints would do is sit in a dark room without eating or socializing or doing anything. I&#8217;m struck by the relevance to depression here, though maybe it&#8217;s a coincidence.</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
	<li class="comment byuser comment-author-blueacritter even thread-odd thread-alt depth-1" id="li-comment-544478">
		<div id="comment-544478" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://1.gravatar.com/avatar/706bcb570414cbb92ccbfc9e6f1cf590?s=40&#038;d=identicon&#038;r=g' srcset='http://1.gravatar.com/avatar/706bcb570414cbb92ccbfc9e6f1cf590?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Sam Reuben</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544478">
			September 6, 2017 at 8:04 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>Scott: have you read Immanuel Kant&#8217;s <i>Critique of Pure Reason</i>? I remember reading somewhere that you were in philosophy as your undergrad, so there&#8217;s a substantial chance of it, but on the off chance you haven&#8217;t yet had the opportunity, I highly recommend it. I (along with some of the commenters in the previous thread) think there&#8217;s a lot of overlap between it and PP &#8211; not total, but close in several key regards. Like Greek atomism, Kant&#8217;s work makes a bunch of claims purely based on sitting down and thinking about the problem which in turn appear to be entirely correct. In particular, his expression of the careful interplay between empirical appearances and concepts as constituting the cognition of objects (as featured in the Transcendental Deduction and elsewhere) is highly predictive of PP, although I&#8217;m still a little on the fence as to whether his Categories were jumping the gun.</p>
<p>If you&#8217;ve read it and think there&#8217;s no relation, then I&#8217;d be interested in hearing.</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment byuser comment-author-admin bypostauthor odd alt depth-2" id="li-comment-544493">
		<div id="comment-544493" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://0.gravatar.com/avatar/c66389ad74ef2a291c76e87c981b0391?s=40&#038;d=identicon&#038;r=g' srcset='http://0.gravatar.com/avatar/c66389ad74ef2a291c76e87c981b0391?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Scott Alexander</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544493">
			September 6, 2017 at 9:00 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>Yeah, see for example <a HREF="http://slatestarcodex.com/2017/08/30/open-thread-83-25/#comment-542673">here</a>, which I still don&#8217;t feel got a really good answer.</p>
<p>I can see the resemblance between this and Kant&#8217;s ideas, but I think in the end PP treats perception as a glorified Photoshop Sharpen Image filter, and Kant treats it as the source of time and space and math and order and everything else.</p>
<p>In particular, Kant&#8217;s whole point was to resolve certain philosophical questions that AFAICT PP doesn&#8217;t do anything to resolve. That makes me think maybe the resemblance is more of a coincidence.</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment byuser comment-author-blueacritter even depth-3" id="li-comment-544512">
		<div id="comment-544512" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://1.gravatar.com/avatar/706bcb570414cbb92ccbfc9e6f1cf590?s=40&#038;d=identicon&#038;r=g' srcset='http://1.gravatar.com/avatar/706bcb570414cbb92ccbfc9e6f1cf590?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Sam Reuben</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544512">
			September 6, 2017 at 10:54 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>Did not see that post! I&#8217;d like to try and answer as best I can.</p>
<p>Part one: Kant was talking in part about mathematical laws, but more critically about the whole project of empirical science. Empirical science is, at its core, this kind of up-down structuring that PP is working with: expectations and sense data interact to create meaningful results. The problem at the time was that the general philosophy was torn between Locke&#8217;s style of hyper-realism and idealism from folks like Berkeley and (although not wholeheartedly) Descartes. That is, from the one direction you had people who were claiming that sense-data gave the full and true story every time, and from the other, people who said only the expectations meant anything. Idealism was pretty well scuttled from the get-go, because nobody <i>really</i> has ever believed it, but Lockean realism had to wait for a refutation by Humean skepticism (e.g. through the problem of induction). The problem there was that Hume didn&#8217;t leave anything really great to go on after the fact, except for a fairly undeveloped notion of &#8220;natural law.&#8221; This is where Kant steps in.</p>
<p>Kant begins by making a pretty bold declaration: in order for empirical science to be possible, we need to have some kind of synthetic <i>a priori</i> cognition. I think the best translation into contemporary lingo is &#8220;hyperpriors,&#8221; although it goes without saying that there are some differences. The idea, at any rate, is that we need to have something plugged into the system from the start in order to get meaningful results, which (surprise surprise) is what machine-learning researchers have discovered, as <a href="http://slatestarcodex.com/2017/09/05/book-review-surfing-uncertainty/#comment-544324">ksvanhorn points out here.</a> As another, yet even stronger version of the claim: Kant says that there is a valid category &#8220;thinking being,&#8221; and that since the category is valid, there are necessary characteristics universal to all thinking beings without which they would not be thinking beings. This is a very, very important idea, which Kant doesn&#8217;t make explicit nearly as well as he ought to, and which has a ton of implications for basically every mind-based field as a foundational belief.</p>
<p>But if we have the necessary information plugged in from the start, what good does the sense data do? Kant&#8217;s answer: there&#8217;s a basic level of sense-molding, which sets everything we experience within the context of space and time (I&#8217;d personally recommend a cautious and conditional expansion of this, but space and time <i>in the experiential sense, not the sense denoted by contemporary science</i> are as universal as you can get), and then everything else is treated by a kind of calculus of sense-data and expectations. The terms he uses, for reference, are &#8220;empirical appearance&#8221; and &#8220;concept,&#8221; respectively, although his use is more subtle and deserves a proper and serious reading rather than blind substitution. The result of this is the cognition of empirical objects, which are the building blocks of science: we declare that a tree is a tree and can be studied as a tree, for example.</p>
<p>So, as a preliminary, why is this basically the same style of work as PP? Simple: because Kant and PP both are trying to explain what goes on in human cognition and perception such that something like empirical science is the best possible method, over (say) Aristotelian examination of scientific syllogisms. The apparent difference is basically just due to the fact that after the immense success of empirical science, with sound philosophy providing theoretical justification for it, there&#8217;s been basically no argument anywhere in the kind of Western academia that PP grew out of as to whether empirical science is the way to go. For the creators of PP, and probably you and me besides, there&#8217;s just never been a question about it. However, I&#8217;d argue that right now we&#8217;re actually in a fairly similar place to where Kant was when he was writing: on the one hand, the Analytic tradition has been trying to push some fairly naive positions about sense-data and mathematics, and on the other hand, the Continental traditions have been trying to undermine those positions with the various sorts of conditioned knowledge and lived experience and what have you (I won&#8217;t try too hard to get terms right here, because no two Continentals use the same ones anyway). Getting lost somewhere in all this kerfuffle is the human mind, which doesn&#8217;t seem to have the kind of perfect grasp of reality required for all the bizarre Analytic thought experiments but also adheres to the world more strongly than a Continental would have it. In to the rescue comes PP, which (unbeknownst to it) is justifying empirical science all over again, as a means of being kind-of-right about the world.</p>
<p>But the bigger question, I think, is about things-in-themselves and where mathematics come from if not from the world, right? I understand why it seems so totally absurd that Kant&#8217;s saying that we&#8217;re just imposing mathematical laws on the world, when those mathematical laws we&#8217;re imposing are good enough to land little metal darts on Mars and then have them sing Happy Birthday. The problem is, basically, that the word you&#8217;re using for &#8220;world&#8221; is what Kant would call the &#8220;empirical world,&#8221; while what Kant says escapes mathematics is the &#8220;things-in-themselves.&#8221; Things-in-themselves form a critical category which is totally absent from most contemporary discourse, which is basically <i>what&#8217;s behind the veil.</i> Consider the old skeptical argument, whether from Descartes&#8217; evil demons or the more pop-culture Matrix, that denies that we&#8217;re experiencing the real world altogether. Are we simply wrong about everything we know, if we&#8217;re living in such a world? No, Kant would say; we&#8217;re right about that entire <i>empirical world.</i> However, the transcendental reality beyond that escapes all our current knowledge, and so we&#8217;re right to say that we don&#8217;t know the <i>ultimate</i> conditions under which we experience everything. What we can do is examine our own nature as minds, though, and from that declare some necessary conditions of experience: for example, that we need to sense time in order to have ordered thoughts, and space to have any experience of an &#8220;external&#8221; world (i.e. a space outside ourselves for that world to be in). This is why mathematics and logic can carry over so well between humans, and even between humans and aliens (yes, Kant wrote about aliens from space, and I&#8217;m not being silly or facetious here). The math may not be what&#8217;s behind the curtain in the end, but because of what we can tell about the structure of mind itself (through the Categories, for Kant), we can know that math will apply to our empirical worlds as well as the empirical worlds for anything with a mind. (This is an incredibly strong claim, and I think he&#8217;s entirely correct, with some hesitation about his particular Categories.)</p>
<p>It is worth noting that Kant is very passionate about insisting that space and time are not features of things-in-themselves, or whatever lies beyond the veil. The justification for this, as I understand it, is that space and time as we know and experience them are features of mind, not of whatever it is that lies beyond the veil. In his book, it&#8217;s miscategorization to try and apply them to what there really is out there. I think he&#8217;d be more amenable to the suggestion that there might be something vaguely analogous out there, but that we really can&#8217;t know anything about it in its ultimate state. Oh, and the reason why he&#8217;s so insistent about that point is because a lot of the deductive arguments towards idealism in his time started out by declaring space or time to be inherent features of the world as it really is. At least in part, it&#8217;s a direct stab at Berkeley. Hope that makes it feel a bit more reasonable.</p>
<p>So, as an overall summary: I&#8217;d say that a properly fleshed-out PP would have to end up declaring perception as the source of math at the very least, and probably time and space along with it, or else fall straight into the good old-fashioned map-territory problem (seriously, math is the best example of an iterative predictive model that&#8217;s non-identical with what&#8217;s under the hood). PP doesn&#8217;t have much to say about Berkeley and Kant doesn&#8217;t have much to say about the hegemony of European science, but that&#8217;s probably more the anachronism than anything, because the same battle seems to be going on behind all the faff with different words. For your black box, ignoring the obvious detail that the aliens could have put a different equation in, the reason why you can understand the answer they would give and they can understand the answer you would give is that there&#8217;s the same fundamental structure of mind shared between you (and you&#8217;re experiencing the same empirical object). All that we need in order to both come to the conclusion that 2 + 2 = 4 is the same basic software vis a vis counting, not some property of what&#8217;s going on behind the scenes or a magical spark going from mind to mind.</p>
<p>That ended up being quite long! I would be happy to go over any part of this in more detail, and if you give me some time to dig up my Kant volume, I can even give you citations. It&#8217;s good stuff, I believe, although Kant made a serious mistake when he tried shifting over to ethics, which is why he ends up saying such weird things there. Hope it all made sense and wasn&#8217;t too much of a bore.</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment byuser comment-author-drossbucket odd alt depth-3" id="li-comment-544513">
		<div id="comment-544513" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://0.gravatar.com/avatar/ca2f017637aeb147043f4ff190661895?s=40&#038;d=identicon&#038;r=g' srcset='http://0.gravatar.com/avatar/ca2f017637aeb147043f4ff190661895?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">drossbucket</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544513">
			September 6, 2017 at 10:57 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>I don&#8217;t know about your open thread question, sorry, but if this is the &#8216;asking confused questions about Kant&#8217; section can I ask mine:</p>
<p>One argument I often see is that the discovery of non-Euclidean geometries messed up Kant&#8217;s program for a priori geometry. I&#8217;ve never really understood that argument, though. </p>
<p>It is really surprising and interesting that the parallel postulate is independent and we can have different geometries. But I don&#8217;t see how this has changed my own inbuilt geometric intuition. Nothing about my perceptual intuition for parallel lines has changed in a way that makes them look more like they ever want to cross! And if I&#8217;m trying to reason about a non-Euclidean geometry and want to visualise something, I&#8217;m still going to do some sort of projection into Euclidean space, e.g. use some model of the hyperbolic plane. </p>
<p>I&#8217;m sure there&#8217;s some horrible German post-Kantian philosopher I should read, but I don&#8217;t know which one.</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment byuser comment-author-blueacritter even depth-4" id="li-comment-544517">
		<div id="comment-544517" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://1.gravatar.com/avatar/706bcb570414cbb92ccbfc9e6f1cf590?s=40&#038;d=identicon&#038;r=g' srcset='http://1.gravatar.com/avatar/706bcb570414cbb92ccbfc9e6f1cf590?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Sam Reuben</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544517">
			September 6, 2017 at 11:18 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>Yeah, the reason you don&#8217;t get that argument is that it doesn&#8217;t work. Kant definitely did the Kant thing and failed to anticipate that there could be some fairly radical expansions to prior fields of knowledge, but although <i>a priori</i> geometry by itself isn&#8217;t so much a thing, <i>a priori</i> Euclidean geometry is a thing, as well as <i>a priori</i> non-Euclidean geometry. Heck, you can even introduce non-Euclidean geometry as a weirder extension of normal geometry and just keep on tickin&#8217;, same as any other field of math. All of this allows for the same basic program for Kant, which is that at no point in the study of any kind of geometry do you absolutely have to stop, go outside, and measure things in order to prove your next point. You might not know what proofs are useful without going outside and noticing, say, that the earth is approximately ball-shaped, but completing them takes zero measuring and experimentation (as opposed to figuring out the gravitational constant). That&#8217;s all he needed in order for it to be properly <i>a priori.</i></p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment byuser comment-author-drossbucket odd alt depth-5" id="li-comment-544524">
		<div id="comment-544524" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://0.gravatar.com/avatar/ca2f017637aeb147043f4ff190661895?s=40&#038;d=identicon&#038;r=g' srcset='http://0.gravatar.com/avatar/ca2f017637aeb147043f4ff190661895?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">drossbucket</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544524">
			September 6, 2017 at 11:46 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>Thanks, that&#8217;s helpful as I could never make much sense of the objection. Agree that that geometry being non-Euclidean doesn&#8217;t stop it being <i>a priori</i>.</p>
<p>I don&#8217;t know, I think I wanted to claim something a bit stronger though. In your long comment above you&#8217;re careful to distinguish &#8216;space and time in the experiential sense, not the sense denoted by contemporary science&#8217;. I kind of want to say that that experiential sense <i>just is</i> Euclidean, and Kant was right!</p>
<p>(I tend to think about flat tangent spaces to curved manifolds in this weird semi-Kantian sense &#8211; that it&#8217;s my local experiential approximation, or something, but that reality might not agree with me on large scales.)</p>
</div>

		<div class="reply">
					</div><!-- .reply -->
	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
	<li class="comment byuser comment-author-douglas-knight even thread-even depth-1" id="li-comment-544480">
		<div id="comment-544480" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://2.gravatar.com/avatar/b8f92132e420e982739a2bce097523af?s=40&#038;d=identicon&#038;r=g' srcset='http://2.gravatar.com/avatar/b8f92132e420e982739a2bce097523af?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Douglas Knight</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544480">
			September 6, 2017 at 8:14 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>What does PP say at high levels that you can tell it diverges from PCT?</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment byuser comment-author-admin bypostauthor odd alt depth-2" id="li-comment-544494">
		<div id="comment-544494" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://0.gravatar.com/avatar/c66389ad74ef2a291c76e87c981b0391?s=40&#038;d=identicon&#038;r=g' srcset='http://0.gravatar.com/avatar/c66389ad74ef2a291c76e87c981b0391?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Scott Alexander</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544494">
			September 6, 2017 at 9:02 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>My impression, which might have been wrong, was something like PCT wanting higher levels to control a scalar quantity (like &#8220;amount of love&#8221;). </p>
<p>PP doesn&#8217;t really present higher level predictions as being motivational (though maybe it could), but if they were I feel like it would be more like &#8220;similarity to my ideal relationship&#8221;.</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
	<li class="comment byuser comment-author-pmgerdes even thread-odd thread-alt depth-1" id="li-comment-544499">
		<div id="comment-544499" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://0.gravatar.com/avatar/6b94914c55cf2beed1845e26da840fa3?s=40&#038;d=identicon&#038;r=g' srcset='http://0.gravatar.com/avatar/6b94914c55cf2beed1845e26da840fa3?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn"><a href='http://rejectingrationality.org' rel='external nofollow' class='url'>Peter Gerdes</a></cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544499">
			September 6, 2017 at 9:15 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>I&#8217;m unclear as to what the content of claiming a PP style perceptual control of action really amounts to.</p>
<p>I mean in what sense isn&#8217;t it true that any system which learns which control signals to provide in order to create a certain desired perceptual state can be redescribed in terms of minimizing predicted error?  In other words given a control system whose goals are understood in terms of certain perceptual states, e.g., an automated vehicle trying to ensure it is between the lines and learning the correct control to apply to the wheels to achieve that, can&#8217;t we always just call the desired behavior (staying between the lines or correcting course by such and such amount) a prediction and thereby vindicate the idea that control is just another instance of minimizing perceptual predictive error?</p>
<p>Maybe there is something I&#8217;m missing but I&#8217;m worried that one could redescribe just about any system which learns which controls to apply by comparing the actual sensory inputs to some desired state could be so described.  The fact that there seems to be considerable freedom in choosing what to call a prediction (it apparently encompass fairly abstract notions that can have pretty attenuated links with the actual sensory input&#8230;as it must if the theory is to handle even rudimentary actions) and little specification of a particular manner in which perceptual predictions are minimized adds to this worry.   If so that would make this model trivially true but also not pretty vacuous.</p>
<p>Maybe it would help if someone could describe a plausible way this kind of learned control behavior could function that is ruled out by this theory.</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment byuser comment-author-honeyoak odd alt thread-even depth-1" id="li-comment-544501">
		<div id="comment-544501" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://2.gravatar.com/avatar/53be37b7c67a9cc5e2bbfcacc86f3620?s=40&#038;d=identicon&#038;r=g' srcset='http://2.gravatar.com/avatar/53be37b7c67a9cc5e2bbfcacc86f3620?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">honeyoak</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544501">
			September 6, 2017 at 9:26 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>Hey scott, one of the issues that bothers me about the whole topic is how bad people are about probability in general. How is having a really bad flood now mean that we shouldn&#8217;t expect a flood for the next 100 years? how is the system generating these (strange) abstract predictions?</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment byuser comment-author-poignardazur even thread-odd thread-alt depth-1" id="li-comment-544510">
		<div id="comment-544510" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://2.gravatar.com/avatar/2c4911244c5abf838d69409b962e2b55?s=40&#038;d=identicon&#038;r=g' srcset='http://2.gravatar.com/avatar/2c4911244c5abf838d69409b962e2b55?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">poignardazur</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544510">
			September 6, 2017 at 10:49 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>This all feels very convenient. In this post, and the book review, you made a lot of claims about the predictive processing model, and how it neatly explains a bunch of different already-existing data.</p>
<p>Isn&#8217;t that a Science Deadly Sin? Like, anyone can look at existing data and say &#8220;Ahah, I know why this happens&#8221;, but only real scientists can say &#8220;This is will happen, this is impossible and will never happen&#8221;?</p>
<p>I feel like these posts need an &#8220;epistemic status&#8221; warning. Unless you&#8217;re seeing something I&#8217;m not seeing, and I&#8217;m just projecting my confusion on you.</p>
<p>But until you put forth some prediction, or some form of model that says &#8220;this is what can happen&#8221; without reusing existing observations&#8230; well, I won&#8217;t be convinced, and I don&#8217;t think anyone should be.</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment byuser comment-author-blueacritter odd alt depth-2" id="li-comment-544514">
		<div id="comment-544514" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://1.gravatar.com/avatar/706bcb570414cbb92ccbfc9e6f1cf590?s=40&#038;d=identicon&#038;r=g' srcset='http://1.gravatar.com/avatar/706bcb570414cbb92ccbfc9e6f1cf590?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Sam Reuben</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544514">
			September 6, 2017 at 11:07 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>The prediction is just that all nearly-thinking things have to work this way, and that anything that works in a different way (e.g. classic computer structure) just doesn&#8217;t qualify as a thinking thing. Anything with an upstream-downstream flow of sense data and expectations and a set of motivating forces will get most of the way there by itself. Anything without those will never get close.</p>
<p>In addition, you can see Scott trying to apply this to his own work with the schizophrenia suggestions. The idea is, of course, that if upstream-downstream malfunction is what&#8217;s going on with most mental illnesses, you can start to predict with greater accuracy which drugs will work there, which currently isn&#8217;t going well at all. Scott, not being an active biomedical chemist, doesn&#8217;t have any particular predictions, but a dedicated research team could come up with some and then test them. (Related: the reason that current drug-effect predictions aren&#8217;t working well could be that existing models don&#8217;t actually explain or predict anything.)</p>
<p>So yeah, this does have the potential to be a just-so story, but it&#8217;s already branching out in the direction of useful forecasting. The theory does come before certain practices sometimes.</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment byuser comment-author-sniffnoy even depth-3" id="li-comment-544515">
		<div id="comment-544515" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://0.gravatar.com/avatar/3d0837be44b824ac35cfa18a263d2a08?s=40&#038;d=identicon&#038;r=g' srcset='http://0.gravatar.com/avatar/3d0837be44b824ac35cfa18a263d2a08?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Sniffnoy</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544515">
			September 6, 2017 at 11:09 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><blockquote><p>The prediction is just that all nearly-thinking things have to work this way, and that anything that works in a different way (e.g. classic computer structure) just doesn’t qualify as a thinking thing.</p></blockquote>
<p>That last bit makes this sound like it is not an actual prediction about the world but rather just a delineation of terminology.  How do you cash it out into an actual prediction?</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment byuser comment-author-blueacritter odd alt depth-4" id="li-comment-544519">
		<div id="comment-544519" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://1.gravatar.com/avatar/706bcb570414cbb92ccbfc9e6f1cf590?s=40&#038;d=identicon&#038;r=g' srcset='http://1.gravatar.com/avatar/706bcb570414cbb92ccbfc9e6f1cf590?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Sam Reuben</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544519">
			September 6, 2017 at 11:23 pm</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>Well, the category &#8220;thinking thing&#8221; has some other requirements that we expect to see. It&#8217;s not like it was just made up for the sake of PP. It&#8217;s a category that was basically made for humans alone, and is tenuously extended with some severe caveats to other animals (some people try it with plants; I don&#8217;t buy it). If something is able to act very much like an animal in how it learns and interacts with the world, then we can put it into the same category as them. If it doesn&#8217;t, we won&#8217;t put it in that same category. Intuition and standard use are what can keep this category grounded, instead of just being so loose as to say whatever we want.</p>
<p>For the record, I think that some of our robots might be at pillbug or earthworm levels of competence. That&#8217;s not saying a lot, but it is quite cool!</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
	<li class="comment byuser comment-author-untimelyreflections even thread-even depth-1" id="li-comment-544530">
		<div id="comment-544530" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://0.gravatar.com/avatar/fbbc001c74db671ee715a2ec74b39328?s=40&#038;d=identicon&#038;r=g' srcset='http://0.gravatar.com/avatar/fbbc001c74db671ee715a2ec74b39328?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">untimelyreflections</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544530">
			September 7, 2017 at 12:49 am</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>This model is very similar to HTM from Jeff Hawkins &#8211; Hierarchical Temporal Memory. The Hawkins model has a *lot* more detail though.</p>
<p><a href="https://en.wikipedia.org/wiki/Hierarchical_temporal_memory" rel="nofollow">https://en.wikipedia.org/wiki/Hierarchical_temporal_memory</a><br />
<a href="https://numenta.org/resources/HTM_CorticalLearningAlgorithms.pdf" rel="nofollow">https://numenta.org/resources/HTM_CorticalLearningAlgorithms.pdf</a></p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment byuser comment-author-stephanahonen odd alt thread-odd thread-alt depth-1" id="li-comment-544532">
		<div id="comment-544532" class="commentholder">
		<div class="comment-author vcard">
			<img alt='' src='http://0.gravatar.com/avatar/6aeb5480a792f57abaceb1530a9a7ce8?s=40&#038;d=identicon&#038;r=g' srcset='http://0.gravatar.com/avatar/6aeb5480a792f57abaceb1530a9a7ce8?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Stephan Ahonen</cite> <span class="says">says:</span>		</div><!-- .comment-author .vcard -->
		
		<div class="comment-meta commentmetadata"><a href="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/#comment-544532">
			September 7, 2017 at 1:27 am</a>		</div><!-- .comment-meta .commentmetadata -->

		<div class="comment-body"><p>This is essentially how a lot of control systems in industrial processing, robotics, aviation, etc work. You have a set of sensors that measure the state of your system, and you have a set of actuators that affect the state of your system, and you use a feedback controller to drive the actuators until your system approaches some target state as measured by the sensors. Autopilot in an aircraft? Feedback controller that detects the aircraft&#8217;s attitude and moves the control surfaces to move the aircraft toward your desired attitude. Nuclear power plant? Feedback controller that moves the control rods in and out to match actual output power with desired output power. Feedback controllers are so exceptionally useful and powerful that quite often you don&#8217;t even any sort of open-loop or predictive controller at all.</p>
<p>I&#8217;ve read a theory that a human being is basically just a shitload of feedback controllers layered on top of each other. Not just proprioception, but all the way up to complex behaviors like &#8220;I am hungry -&gt; seek food to reduce hunger&#8221;. No word on whether this extends all the way up to things like &#8220;I want to be stronger -&gt; Spend the next six months in a gym.&#8221;</p>
</div>

		<div class="reply">
			<a rel="nofollow" class="comment-reply-login" href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">Log in to Reply</a>		</div><!-- .reply -->
	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
			</ol>


	</div><!-- #comments -->


	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/09/06/predictive-processing-and-perceptual-control/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://slatestarcodex.com/wp-login.php?redirect_to=https%3A%2F%2Fslatestarcodex.com%2F2017%2F09%2F06%2Fpredictive-processing-and-perceptual-control%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	

			</div><!-- #pjgm-content -->
		</div><!-- #pjgm-box -->

<div id="primary" class="widget-area" role="complementary">
	<a class="sidebar-toggle" title="Expand Sidebar"><i class="fa fa-angle-double-left"></i><i class="fa fa-angle-double-right"></i></a>
	<ul class="xoxo">
		<li id="meta-2" class="widget-container widget_meta"><h3 class="widget-title">Meta</h3>			<ul>
			<li><a href="https://slatestarcodex.com/wp-login.php?action=register">Register</a></li>			<li><a href="https://slatestarcodex.com/wp-login.php">Log in</a></li>
			<li><a href="http://slatestarcodex.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="http://slatestarcodex.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</li><li id="blog_subscription-2" class="widget-container jetpack_subscription_widget"><h3 class="widget-title">Subscribe via Email</h3>
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
				<div id="subscribe-text"></div>					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-2">
							Email Address						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-2" placeholder="Email Address" />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="http://slatestarcodex.com/2017/09/06/predictive-processing-and-perceptual-control/" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-2" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-2]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-2'),
					input = d.getElementById('subscribe-field-blog_subscription-2'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</li><li id="arvins_ad_randomizer-2" class="widget-container widget_arvins_ad_randomizer"><div class="widget-text arvins_ad_randomizer_box"><div class="aar_div"><p><center><A HREF="https://www.beeminder.com/"><IMG SRC="http://slatestarcodex.com/blog_images/beeminder_ad.png"></A></center></p>

<p>Beeminder's an evidence-based willpower augmention tool that collects quantifiable data about your life, then helps you organize it into commitment mechanisms so you can keep resolutions. They've also got a blog about what they're doing <A HREF="http://blog.beeminder.com/tag/rationality/">here</A></p></div><div class="aar_div"><p><center><A HREF="https://80000hours.org/career-guide/?utm_source=ssc&utm_campaign=2017-04+Sidebar+Ad&utm_medium=blog"><IMG SRC="http://slatestarcodex.com/blog_images/80k_vertise.png"></A></center></p>

<p>80,000 Hours researches different problems and professions to help you figure out how to do as much good as possible. Their <A HREF="https://80000hours.org/career-guide/?utm_source=ssc&utm_campaign=2017-04+Sidebar+Ad&utm_medium=blog">free career guide</A> show you how to choose a career that's fulfilling and maximises your contribution to solving the world's most pressing problems.</p></div><div class="aar_div"><p><center><A HREF="https://www.metaculus.com/questions/?show-welcome=true"><IMG SRC="http://slatestarcodex.com/blog_images/metaculus_vert.jpg"></A></center></p>

<p>Metaculus is a platform for generating crowd-sourced predictions about the future, especially science and technology. If you're interested in testing yourself and contributing to their project, check out their <A HREF="https://www.metaculus.com/questions/">questions page</A></p>
</div><div class="aar_div"><p><center><A HREF="https://www.breakdown-notes.com/"><IMG SRC="http://slatestarcodex.com/blog_images/vert_breakdown.png"></A></center></p>

<p><A HREF="https://www.breakdown-notes.com/">Breakdown Notes</A> is an online tool to make notes, diagrams, or mindmaps in your browser. It has a free version with ads, and a paid version without.</p>





</div><div class="aar_div"><p><center><A HREF="http://www.mealsquares.com/"><IMG SRC="http://slatestarcodex.com/blog_images/mealsquares_ad.png"></A></center></p>

<p>MealSquares is a "nutritionally complete" food that contains a balanced diet worth of nutrients in a few tasty easily measurable units. Think Soylent, except zero preparation, made with natural ingredients, and looks/tastes a lot like an ordinary scone. </p></div><div class="aar_div"><p><center><A HREF="http://effectivealtruism.org/?refer=ssc"><IMG SRC="http://slatestarcodex.com/blog_images/eatowr.jpg"></A></center></p>

<p>The <A HREF="http://effectivealtruism.org/?refer=ssc">Effective Altruism newsletter</A> provides monthly updates on the highest-impact ways to do good and help others.</p></div><div class="aar_div"><p><center><A HREF="https://www.patreon.com/user?u=926060&ty=h"><IMG SRC="http://slatestarcodex.com/blog_images/patreon_ad.png" style="border:1px solid black"></A></center></p>

<p>Support this blog by donating through <A HREF="https://www.patreon.com/user?u=926060&ty=h">Patreon</A>.</p></div><div class="aar_div"><p><center><A HREF="https://www.janestreet.com/join-jane-street/open-positions/?utm_source=ssc&utm_medium=banner&utm_campaign=trading&utm_term=trading&utm_content=sierpinski"><img src="https://slatestarcodex.com/blog_images/sierpinski-low_res.png" srcset="https://slatestarcodex.com/blog_images/sierpinski-low_res.png 1x, https://slatestarcodex.com/blog_images/sierpinski_med_res.png 2x"></A></center></p>

<p><A HREF="https://www.janestreet.com/join-jane-street/open-positions/?utm_source=ssc&utm_medium=banner&utm_campaign=trading&utm_term=trading&utm_content=sierpinski">Jane Street</A> is a quantitative trading firm with a focus on technology and collaborative problem solving. We're always hiring talented programmers, traders, and researchers and have internships and fulltime positions in New York, London, and Hong Kong. No background in finance required.</p>
</div><div class="aar_div"><p><center><A HREF="https://www.givingwhatwecan.org/?refer=ssc"><IMG SRC="http://slatestarcodex.com/blog_images/eatowr2.jpg"></A></center></p>

<p><A HREF="https://www.givingwhatwecan.org/">Giving What We Can</A> is a charitable movement promoting giving some of your money to the developing world or other worthy causes. If you're interested in this, consider taking their Pledge as a formal and public declaration of intent.</p></div><div class="aar_div"><p><center><A HREF="http://triplebyte.com/?ref=slatestarcodex"><IMG SRC="http://slatestarcodex.com/blog_images/triplebyte_ad.png"></A></center></p>

<p><A HREF="http://triplebyte.com/?ref=slatestarcodex">Triplebyte</A> is building an objective and empirically validated software engineering recruitment process. We don’t look at resumes, we just look at whether you can code. We’ve had great success helping Slate Star Codex readers get jobs in the past. We invite you to test your skills and try our process!</p></div><div class="aar_div"><p><center><A HREF="https://relationshiphero.com/?c=ssc"><IMG SRC="http://slatestarcodex.com/blog_images/vert_relationship.png"></A></center></p>

<p><A HREF="https://relationshiphero.com/?c=ssc">Relationship Hero</A> connects you to a live expert who gives you tactical step-by-step advice for any human relationship: your date, spouse, family, friend, coworker, etc. It's only $1/minute.</p></div></div></li>	</ul>
</div><!-- #primary .widget-area -->
			</div><!-- #pjgm-main -->
			<div id="pjgm-footer">
				<div id="pjgm-ender">
					<a href="/amazon" title="Semantic Personal Publishing Platform" rel="generator">
						Part of Amazon affiliate program					</a>
					<a href="http://www.hulozila.com/" title="Hulozila" rel="designer"> </a>
				</div><!-- #pjgm-ender -->
			</div><!-- #pjgm-footer -->
		</div><!-- #pjgm-wrap -->
		<script>
    jQuery(document).ready(function () {
		jQuery.post('http://slatestarcodex.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var F = new Function ( response );
			return( F() );
		});
    });
</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/slatestarcodex.com\/2017\/09\/06\/predictive-processing-and-perceptual-control\/":4603};
	</script>
<script type='text/javascript' src='http://slatestarcodex.com/wp-includes/js/comment-reply.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201736'></script>
<script type='text/javascript' src='http://slatestarcodex.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=2.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pmcc_ajax = {"ajaxurl":"https:\/\/slatestarcodex.com\/wp-admin\/admin-ajax.php","errors":{"thank_you_message":"Reported.","invalid_nonce_message":"It seems you already reported this comment.","invalid_values_message":"Cheating huh?","already_flagged_message":"It seems you already reported this comment.","already_flagged_note":"Comment has been flagged already."}};
/* ]]> */
</script>
<script type='text/javascript' src='http://slatestarcodex.com/wp-content/plugins/crowd-control/js/ajax.js?ver=20150929'></script>
<script type='text/javascript' src='http://slatestarcodex.com/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://slatestarcodex.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.2.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201736.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.2.1',blog:'46701818',post:'4603',tz:'-7',srv:'slatestarcodex.com'} ]);
	_stq.push([ 'clickTrackerInit', '46701818', '4603' ]);
</script>
		<script src="https://bakkot.github.io/SlateStarComments/ssc.js"></script>

		<script>
			jQuery(function() {

				/*  Sidebar collapse
				/* ------------------------------------ */

				jQuery('#primary .sidebar-toggle').click(function(){
					jQuery('body').toggleClass('s1-collapse').toggleClass('s1-expand');
					if (jQuery('body').is('.s2-expand')) {
						jQuery('body').toggleClass('s2-expand').toggleClass('s2-collapse');
					}
				});
				jQuery('#left-sidebar .sidebar-toggle').click(function(){
					jQuery('body').toggleClass('s2-collapse').toggleClass('s2-expand');
					if (jQuery('body').is('.s1-expand')) {
						jQuery('body').toggleClass('s1-expand').toggleClass('s1-collapse');
					}
				});
			});
		</script>
	</body>
</html>
